В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gallyamovdenis
gallyamovdenis
15.01.2020 04:37 •  Информатика

Составить программу. дано натуральное число n. подсчитать количество цифр этого числа.

Показать ответ
Ответ:
yulyamazelyuk
yulyamazelyuk
19.07.2020 13:23
Var
  n: longint;
  s: string;
  k: byte;

begin
  Write('Введите натуральное число '); Readln(n);
  { Преобразуем число к строке, убрав знак (мало ли...) }
  Str(abs(n), s);
  { Выведем длину полученной строки }
  Writeln('Количество цифр в числе равно ', Length(s))
end.

Тестовое решение:
Введите натуральное число 164275353
Количество цифр в числе равно 9
0,0(0 оценок)
Ответ:
sasha2054
sasha2054
19.07.2020 13:23
Program chisla;
uses crt;
var a,b,c: integer;
begin
writeln('Введите натуральное число: ');
readln(a);
b:=a;
c:=0;
while b <>0 do
begin
c:=c+1;
b:= b div 10;
end;
writeln('B числе ',a,' - ',c, ' цифр');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота