В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
HGRM
HGRM
17.06.2022 13:37 •  Информатика

Составить программу даны 3 числа a b c. если сумма первых двух чисел меньше третьего числа. увеличить каждое из чисел в два раза. если нет возвести числа в квадрат. схемой

Показать ответ
Ответ:
rahmaevrail201
rahmaevrail201
03.10.2021 04:50
В шестеричной системе алфавит состоит из цифр 0,1,...5.
Четырехразрядное число по условиям задания (1) и (2) имеет вид aabb,
где a=1,2,...5, b=0,1,...5.
В развернутой записи число имеет вид
a×6³+a×6²+b×6+b×1 = 6²×a(6+1)+b(6+1) = 7(36a+b)
При этом по условию (3) можно записать, что k² = 7(36a+b)
Чтобы число 7(36a+b) было полным квадратом, 36a+b должно быть кратно 7, а остаток от деления (36a+b) на 7 также должен быть полным квадратом.
Получаем, что 36a+b = 7m²
Минимальное значение 36a+b равно 36×1+0 = 36, следовательно m>2 (при m=2 получим 7×4=28, что меньше 36).
При m=3 получаем 36a+b = 63 и при a∈[1;5], b∉[0;5] решений нет.
При m=4 получаем 36a+b = 112 и находим a=3, b=4 - есть решение!
При m=5 получаем 36a+b = 175 и при a∈[1;5], b∉[0;5] решений нет.
При m=6 получаем 36a+b = 175 и получаем, что a=7, а это недопустимо. Дальше смысла проверять нет.
Итак, a=3, b=4, число 3344₆ = 7×(36×3+4) = 784₁₀ = 28²

ответ: 3344
0,0(0 оценок)
Ответ:
Someoneone
Someoneone
29.09.2021 04:09
Var a, b: integer;
var c: string;
begin
writeln('Введите 1 число.');
readln(a);
writeln('Введите 2 число.');
readln(b);
writeln('Знак операции.');
readln(c);
if c='*' then writeln(a*b);
if c='/' then writeln(a/b);
if c='-' then writeln(a-b);
if c='+' then writeln(a+b);
end.
2 ЗАДАЧА 
var a, b: real;
begin
writeln('Зарабаток Пети:');
readln(a);
writeln('Зарабаток Петрова:');
readln(b);
if a>b then writeln('Петя заработал больше Петрова.')
else if a=b then writeln('Петров и Петя заработали одинаково.')
else
writeln('Петров заработал больше Пети.');
writeln('Среднее: ', (a+b)/2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота