В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу для графического учебного исполнителя для написания слова ПОТ


Составить программу для графического учебного исполнителя для написания слова ПОТ

Показать ответ
Ответ:
samira21111
samira21111
20.01.2022 08:32

Создать файл X компонентами которого являются элемента массива M. Переписать из файла X в файл Y все компоненты, которые стоят на четных местах. Прочитать файл Y.

M = (0,1; 5,6; 0.8; 2,4; 7,3; 6,8; 0,5; 2,3;)

Решение

 

Описание переменных:  

M - массив-константа;

x, y - переменные, связанные с типизированными файлами;

n - считанное из файла очередное число;

i - счетчик.

Алгоритм решения задачи:  

Создать константу-массив, присвоив ей заданные значения массива.

Связать файловые переменные с соответствующими файлами.

Открыть файл X на запись. Записать в него все элементы массива. Закрыть файл.

Открыть файл X на чтение, а файл Y на запись. Присвоить счетчику значение 1. Пока не будет достигнут конец файла X, считывать из него очередное число. Если при этом счетчик имеет четное значение, то записывать число в файл Y. После считывания и проверки на четность номера очередного числа, увеличивать счетчик на 1. После того как файл X будет прочитан, закрыть оба файла.

Открыть файл Y на чтение. Пока не будет достигнут его конец, считывать из него очередное число и выводить его на экран. После завершения цикла закрыть файл.

Программа на языке Паскаль:  

 

const M: array[1..8] of real = (0.1, 5.6, 0.8, 2.4, 7.3, 6.8, 0.5, 2.3);

var  

   x,y : file of real;

   n: real;

   i: byte;

begin

   assign(x,'x.dat');

   assign(y,'y.dat');

 

   rewrite(x);

   for i:=1 to 8 do

       write(x, M[i]);

   close(x);

 

   reset(x);

   rewrite(y);

   i := 1;

   while not EOF(x) do begin

       read(x, n);

       if not odd(i) then

           write(y, n);

       i := i + 1;

   end;

   close(x);

   close(y);

 

   reset(y);

   while not EOF(y) do begin

       read(y, n);

       write(n:5:1);

   end;

   writeln;

   close(y);

Объяснение:

0,0(0 оценок)
Ответ:
shpirnoroman
shpirnoroman
01.01.2021 04:00
В глубокой древности - на стенах пещер, на глиняных табличках, восковых дощечках, на скрижалях, потом на папирусе, бересте, пергаменте и т. д. Потом изобрели бумагу. В старину писали стилом, палочками, гусиными перьями, углями. Были ещё какие-то средства. В девятнадцатом веке изобрели пишущие машинки, фотоаппараты - ведь запечатление изображений на фотоплёнках и фотопластинках, это тоже запись информации. Также в 19 столетии появились граммофоны, патефоны, механические пианино, шарманки (музыка - тоже информация) . А уже ближе к нашим временам появились магнтитофоны, видеомагнтитофоны, потом лазерные устройства для записи на диски. Наконец, мобильники, фотоаппараты, компьютеры - это тоже накопители информации, которая хранится на дисках, флэшках, картах памяти и т. д. В общем, сам поищи в интернете, напиши разные варианты для поиска, например, "древние записи информации", "старинные носители информации", "папирус, глина, берестяные грамоты, письмена", "Александрийская библиотека" и т. д.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота