В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
рыттп
рыттп
07.03.2023 17:34 •  Информатика

Составить программу для нахождения наибольшего общего делителя четырёх натуральных чисел используя процедуру

Показать ответ
Ответ:
muratovsergej
muratovsergej
01.10.2020 21:22
Program z1;
var a,b,c,d:integer;
procedure nod(x,y:integer;var nod2:integer);
begin
        while x<>y do begin
                if x>y then begin
                        x:=x-y
                end
                else begin
                        y:=y-x
                end
        end;
        nod2:=xend;
begin
        write('a=');readln(a);
        write('b=');readln(b);
        write('c=');readln(c);
        write('d=');readln(d);
        nod(a,b,b);
        nod(b,c,c);
        nod(c,d,d);
        writeln('nod=',d);
        readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота