Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
KattyDark010203
23.12.2020 00:08 •
Информатика
Составить программу для определения, является ли натуральное число k степенью числа 3 borland c
Показать ответ
Ответ:
Razzey
24.06.2020 12:21
На С++ думаю что то же, что и на С
#include <iostream>
#include <math.h>
using namespace std;
int main() {
int n;
cin>>n;
while (n>2) { n=n/3;}
if (n==1) {cout<<"YES";} else
cout<<"NO";}
0,0
(0 оценок)
Популярные вопросы: Информатика
bogussasa7
18.02.2023 09:00
Какое время в секундах понадобиться для передачи файлов объемом восемь мбайт если скорость передачи данных по каналу связи составляет два в двацать первой степени бит в секунду...
Илончик10
18.02.2023 09:00
По следующему словесному описанию алгоритма восстановите формулу: 1) 2 умножить на х, результат обозначить а 2) из 3 вычесть х, результат обозначить в 3) 5 умножить на в, результат...
lovelyre
11.11.2020 00:39
При копировании формулы из ячейки в4 в ячейку d7 в последнюю была занесена формула =е7+8. что было записано в ячейке в4?...
vikbyk
11.11.2020 00:39
Где окажется выполнитесь,выполнивший 16 раз подряд следующую группу команд? пройти 10 метров вперед повернуть на 90 градусов по часовой стрелке...
coolplayer1
11.11.2020 00:39
Втаблице dat хранятся данные о количестве детских праздников, которые проводило кафе за последний год (dat[1] — количество детских праздников в январе, dat[2] — количество праздников...
максим1714
17.04.2020 17:38
Файл размером 1.5mb передается по сети со скоростью 100kbit/sec.сколько времени в секундах потребуется для передачи всего файла?...
SuperDusia
17.04.2020 17:38
Вexcel ! 1 фирма «новый путь» закупила новые автомобили: ваз-21093 –35 шт. по цене $2000, газ-31029- 10шт по цене $2100, ваз-2106- 21 шт. по цене $1600). на машины были поставлены...
A1n2g3e4l5i6n7a87
25.06.2022 11:52
Сформировать двумерный массив а(10*5) через random(50). распечатать в виде таблицы. на основании этого массива сформировать одномерный массив в из сумм значений элементов каждой...
milka230614
17.01.2023 06:30
Перевести в десятичную систему 1114(8), 576(8), 11001100(2)...
CBeTouD
06.11.2021 18:16
Выполнить описание предметной области справочник аудиторий (номер аудитории,корпус,вместимость,особенности(например,нет доски),спецоборудование) . составить список запросов (минимум...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <iostream>
#include <math.h>
using namespace std;
int main() {
int n;
cin>>n;
while (n>2) { n=n/3;}
if (n==1) {cout<<"YES";} else
cout<<"NO";}