В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Hohlond
Hohlond
06.11.2021 05:08 •  Информатика

Составить программу для pascalabc: статья, набранная на компьютере, содержит х страниц, на каждой странице y строк, в каждой строке z символов. определите информационный объём статьи в битах, байтах и килобайтах,если каждый символ кодируется 8 битами.

Показать ответ
Ответ:
anytka1312
anytka1312
25.05.2021 12:29

var

a,i,n,a1:integer;

begin

a1:=30000;

read(n);

for i:=1 to n do begin

read(a);

if (a<a1) and (a div 10 <10) and (a div 10 >1)and (a mod 2 = 0) then a1:=a;

end;

writeln(a1);

end.

var

b,x,c:real;

i,n,a:integer;

begin

x:=0;

b:=0;

read(n);

for i:=1 to n do begin

read(a);

if (a mod 7 = 0) or (a mod 3 = 0) then b:=b+a;

if (a mod 7 =0) or (a mod 3 = 0) then x:=x+1;

end;

c:=b/x;

writeln(c);

end.

var

a,b,x,i,n:integer;

begin

x:=0;

read(n);

for i:=1 to n do begin

read(a);

if (a mod 10 <>1) and (a mod 2 = 1) then x:=x+1;

end;

writeln(x);

end.

0,0(0 оценок)
Ответ:
Кей121
Кей121
25.05.2021 12:29

var

a,i,n,a1:integer;

begin

a1:=30000;

read(n);

for i:=1 to n do begin

read(a);

if (a<a1) and (a div 10 <10) and (a div 10 >1)and (a mod 2 = 0) then a1:=a;

end;

writeln(a1);

end.

var

b,x,c:real;

i,n,a:integer;

begin

x:=0;

b:=0;

read(n);

for i:=1 to n do begin

read(a);

if (a mod 7 = 0) or (a mod 3 = 0) then b:=b+a;

if (a mod 7 =0) or (a mod 3 = 0) then x:=x+1;

end;

c:=b/x;

writeln(c);

end.

var

a,b,x,i,n:integer;

begin

x:=0;

read(n);

for i:=1 to n do begin

read(a);

if (a mod 10 <>1) and (a mod 2 = 1) then x:=x+1;

end;

writeln(x);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота