В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mashamaxi
mashamaxi
15.02.2020 01:38 •  Информатика

Составить программу для платы microbit, в которой "бьётся" сердце на экране с частотой 60 ударов в минуту. При нажатии на кнопку "B" выводится температура окружающего воздуха (с форматированием temperature показания C). При касании контакта "1" выводится угол поворота платы от направления на север ( с форматированием Heading показания degree)​

Показать ответ
Ответ:
roksanaatalan
roksanaatalan
20.06.2021 10:36

#include<iostream>

#include<clocale>

using namespace std;

int main(){

setlocale(LC_CTYPE, "");

cout << "Введите a, b и c\n";

double a, b, c;

cin >> a >> b >> c;

if (a == 0) {

 cout << "Коэффицент а не может быть равен нулю!";

}

double D = powl(b, 2) - 4 * a * c;

if (D > 0)

{

 cout << "два корня: x1=" << (b - sqrt(D)) / (-2 * a) << endl;

 cout << "x2=" << (b + sqrt(D)) / (-2 * a);

}

else if (D == 0)

{

 cout << "Один корень, но считать мы его не будем";

}

else

{

 cout << "Корней нет";

}

return 0;

}

0,0(0 оценок)
Ответ:
iPadmaksi123
iPadmaksi123
15.04.2020 00:36

Короче. Вот код.

def matrix_gen(gen, n, m):    Matrix = [];    for i in range(n):        a = [];        for j  in range(m):            a.append(gen[j]);        Matrix.append(a);    return Matrix;

Объяснение

Сначало ты инициализируешь функицю с названием "matrix_gen", которая принимает 3 параметра, 'gen' -- это генератор которые ты будешь использовать. 'n' & 'm' это размер матрицы.

Второй строчкой ты инициалихируешь пустой массив, которые похже заполнишь. Третей строчкой ты в for цикле обходишь все строки матрицы, они же подмассивы массива  Matrix, просто 'a'. Делаем мы это 'n' раз.

Четвётрой строчкой ты инициализируешь массив(ы, мы в цикле) 'a', и следующей строчкой заполняешь уже его. Так же в for цикле. Всего в нём будет 'm' элементов.

Надеюсь решение правильное. Честно говоря у тебя вопрос очень странно поставлен.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота