Составить программу для решения алгебраической неровности на языке С++ Программа должна для заданных значений числовых коэффициентов a, b и c определять решение в виде промежутков на числовой оси. Выполнить программу для различных значений коэффициентов a, b и c так, чтобы продемонстрировать ее работу по всем возможными ветками разветвления.
a: array [1..30] of integer;
i, s, k: integer;
beginfor i := 1 to 30 do//заполнение рандомными числами(от -15 до 50, включая и -15 и 50) массив
a[i] := random(-15, 50);
for i := 1 to 30 do//сумма элементов и подсчет кратных 3
begin
s := s + a[i];//сумма элементов
if a[i] mod 3 = 0 then//подсчет кол во кратных 3
k := k + 1;
end;
writeln('Исходный массив');
for i := 1 to 30 do
writeln('A[', i, '] = ', a[i]);
writeln('Сумма элементов массива: ', s);
writeln('Кратных 3: ', k);
end.
извини бы дальше но дела но вот подсказки:
2) метод пузырька посмотри
3) там через функцию поиска и удаления
если над у меня есть группа в вк называется просто программки если интересно можешь глянуть
Важное замечание: Программа будет работать только при компиляции компилятором, поддерживающим стандарт C99.
#include <stdio.h>
#include <stdlib.h>
int compare(const int* A, const int* B); // компаратор для qsort
int main()
{
int N;
printf("Введите размер массива: ");
scanf("%d", &N);
int
arr[N],
sum = 0,
number = 0;
for(int i = 0; i < N; i++)
scanf("%d", &arr[i]);
for(int i = 0; i < N; i++)
printf("%d ", arr[i]);
printf("\n");
for(int i = 0; i < N; i++)
{
if(arr[i])
sum += arr[i];
if((arr[i] % 3 == 0) && (i % 2 == 0))
number += 1;
}
qsort(arr, N, sizeof(int), compare);
for(int i = 0; i < N; i++)
printf("%d ", arr[i]);
printf("\nСумма положительных элементов = %d\n\
количество элементов, имеющих четные порядковые номера и являющиеся нечетными числами = %d", sum, number);
return 0;
}
int compare(const int* A, const int* B)
{
return *A - *B;
}