В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
03166
03166
31.10.2021 06:45 •  Информатика

Составить программу для решения следующей : дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. замените все отрицательные элементы максимальным. выведите на экран исходный и измененный массивы.

Показать ответ
Ответ:
nnk1Eer7
nnk1Eer7
25.06.2020 17:59
var
i,max:integer;
ar:array[0..200] of integer;

begin
randomize;
max:=0;

for i:=1 to 200 do begin
ar[i]:=random(200+1)-100;
if (ar[i] > max) then max:=ar[i];
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;

writeln();

for i:=1 to 200 do begin 
if (ar[i] < 0) then ar[i]:=max; 
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' '); 
end;

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота