Составить программу для решения следующей задачи: Сбербанк начисляет 2% годовых. Выведите на экран, какой станет сумма вклада S, положенная в сбербанк на N лет. Значения S и N вводятся с клавиатуры.
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016 // Внимание! Если программа не работает, обновите версию!
begin var M:=ArrRandom(ReadInteger('x='),-50,50); M.Println; var pa:=M.Where(p->p>3).Average; Writeln('Среднее арифметическое чисел, превышающих 3: ',pa); var pm:=M.TakeLast(10).Max; Writeln('Максимум из десяти последних чисел: ',pm); var pp:=pm/pa; Writeln('Отношение двух найденных величин: ',pp); Writeln('Сформированный массив'); var C:=M.Where(p->p>pp).ToArray; C.Println end.
Пример x= 15 2 -44 30 49 -36 47 -38 -21 -50 3 -5 50 37 -8 -18 Среднее арифметическое чисел, превышающих 3: 42.6 Максимум из десяти последних чисел: 50 Отношение двух найденных величин: 1.17370892018779 Сформированный массив 2 30 49 47 3 50 37
Формула: I=Ki и N=2 ^{i}
K =30 N=128 найти I
решение
N= 2 ^{i} 128 =2 ^{7} i=7 бит
I =Ki =30•7 =210 бит
2.
l =Ki
N= 2^{i}
I = объем информации
k = кол-во символов
i = минимальное кол-во бит для кодирования одного символа
N = мощность алфавита;
k = 64•256 = 16384
N= 32
i = ㏒_{2} 32 = 5 бит
I = 16384 • 5 = 81920 (бит) = 10240 (байт) = 10 Кбайт
ответ: 10 Кбайт
3.
0,5 Кбайта • 1024= 512 байта
4.
Извини, не могу решить, вроде решил а потом перерешил и неправильно, вот что есть уж пока:
На один символ - 1 байт
30 строк по 50 символов = 1500 символов
3 страницы - это 4500 символов
ответ: 4500 байт!
// Внимание! Если программа не работает, обновите версию!
begin
var M:=ArrRandom(ReadInteger('x='),-50,50); M.Println;
var pa:=M.Where(p->p>3).Average;
Writeln('Среднее арифметическое чисел, превышающих 3: ',pa);
var pm:=M.TakeLast(10).Max;
Writeln('Максимум из десяти последних чисел: ',pm);
var pp:=pm/pa;
Writeln('Отношение двух найденных величин: ',pp);
Writeln('Сформированный массив');
var C:=M.Where(p->p>pp).ToArray; C.Println
end.
Пример
x= 15
2 -44 30 49 -36 47 -38 -21 -50 3 -5 50 37 -8 -18
Среднее арифметическое чисел, превышающих 3: 42.6
Максимум из десяти последних чисел: 50
Отношение двух найденных величин: 1.17370892018779
Сформированный массив
2 30 49 47 3 50 37