В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
дира3
дира3
01.11.2020 15:26 •  Информатика

Составить программу для решения : "ввести число, обозначающее размер одной фотографии в мбайтах. определить, сколько фотографий поместится на флэш-карту объёмом 2 гбайта." язык программирования: pascal

Показать ответ
Ответ:
tatulia32
tatulia32
06.10.2020 00:24
1. С вещественными числами

var
  k:real;
begin
  Write('Размер фотографии, мб: '); Read(k);
  Writeln('На flash-card объемом 2 Гб поместится фото: ',
    Trunc(2*1024/k))
end.

Пример
Размер фотографии, мб: 3.27
На flash-card объемом 2 Гб поместится фото: 626

2. С целыми числами

var
  k:integer;
begin
  Write('Размер фотографии, мб: '); Read(k);
  Writeln('На flash-card объемом 2 Гб поместится фото: ',2*1024 div k)
end.

Пример
Размер фотографии, мб: 3
На flash-card объемом 2 Гб поместится фото: 682
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота