В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
3xoTualetnogo6a4ka
3xoTualetnogo6a4ka
16.02.2023 17:50 •  Информатика

Составить программу для решения задачи:
Абонент пользуется следующим тарифом мобильной связи:
ежемесячный платеж составляет 250 рублей
пакет оплачиваемых этой суммой услуг составляет:
• 400 минут связи
• 500 смс
• 3 Гб интернет-трафика
Услуги, превышающие эти нормы, оплачиваются по следующему тарифу:
• 1,2р. за 1 минуту связи
• 1,5р. за 1 смс
• 1,3р. за 1 Мб интернет-трафика
В конце месяца вычисляется объем предоставленных услуг и списывается соответственная плата за месяц. Составить программу для вычисления суммы, которую должен оплатить абонент, для введенных данных: М – количество минут, которые были потрачены за месяц, С – количество смс, I – объем интернет-трафика (в мегабайтах).

Показать ответ
Ответ:
lenin1488
lenin1488
14.04.2021 10:06
// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
begin
  var n:=5;
  var z:=MatrixRandom(n,n,10,99);
  for var i:=0 to n-1 do begin
    for var j:=0 to n-1 do Print(z[i,j]);
    Writeln
    end;
  var imin:=0;
  var jmin:=n-1;
  for var i:=1 to n-1 do
    if z[i,n-i-1]<z[imin,jmin] then begin
      imin:=i; jmin:=n-i-1
      end;
  Writeln('Zmin=Z[',imin+1,',',jmin+1,']=',z[imin,jmin])
end.

Тестовое решение:
26 62 62 90 76
21 67 69 43 37
18 19 35 88 91
60 91 87 46 27
49 71 16 77 81
Zmin=Z[3,3]=35

Замечание:
В массиве элементы нумеруются от 0 до 4, а при выводе номера индексов указаны для нумерации от 1 до 5 (так привычнее смотрится).
0,0(0 оценок)
Ответ:
Alex1t0
Alex1t0
06.06.2021 19:53

Цель данного проекта " Мир без интернета "это установить уровень Интернет-зависимости  учащихся школы, а так же выявить преобладающие типы зависимости.

Задачи у них в общем сумме 6

Задачи:

1)Определить как часто и сколько времени подростки тратят на пользование Интернетом.

2)Выявить  сущность и основные признаки Интернет-зависимости.

3)Проанализировать основные причины возникновения Интернет – зависимости.

4)Установить, кто контролирует процесс пользования Интернетом подростками и есть ли вообще такой контроль.

5)Провести социальный опрос на выявление интернет-зависимости.

6)Составить рекомендации по сохранению здоровья при работе детей за компьютером в школе и дома.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота