В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
likeaboss2005
likeaboss2005
02.04.2020 15:59 •  Информатика

Составить программу для решения задачи в среде Visual Studio. Задача: Если бы рабочий выполнил план, то он получил бы S руб. он выполнил план на М%. Вывести сколько рублей получил рабочий.

Показать ответ
Ответ:
mrYaroslav2020
mrYaroslav2020
18.01.2021 16:54
 Информационный объект — это описание некоторой сущности (реальногообъекта, явления, процесса, события) в виде совокупности логически связанных реквизитов (информационных элементов)
 Компьютер это-Электронно-вычислительная машина .   Информация- сведения независимо от формы их представления.
 Персональный компьютер, ПК (англ. personal computer, PC), ПЭВМ (персональная электронно-вычислительная машина) — настольная микро-ЭВМ, имеющая эксплуатационные характеристики бытового прибора и универсальные функциональные возможности.
0,0(0 оценок)
Ответ:
alekseyblohinov
alekseyblohinov
25.09.2022 05:27
1. Если не использовать функцию возведения в степень, то так:
#include <iostream>
using namespace std;

int main()
{
    int n;
    double s=0;
    double st;
    cout << "Введите n: ", cin >> n, cout << "\n";
    for (int i=1; i<=n; i++) {
    st = 1;
    for (int j=1; j<=i; j++) st *=i;
    s += (double)1/st;
    }
    cout << s;
    return 0;
}

Пример:
Введите n:
3
1.28704

2. Если использовать функцию pow(), то так:
#include <iostream>
#include <cmath>
using namespace std;

int main()
{
    int n;
    double s=0;
    cout << "n = ", cin >> n;
    for (int i=1; i<=n; i++) s += (double)1/pow(i,i);
    cout << s;
    return 0;
}

Пример:
n = 3
1.28704
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота