В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
animebit81
animebit81
28.01.2021 14:08 •  Информатика

Составить программу для ввода с клавиатуры некоторого массива чисел типа integer или real с правильным диалогом программы и пользователя. на всякий случай: имена переменных в программах у обучающихся совпадать не должны. также следует обеспечить диалог с пользователем. в программе обязательны ! комментарий по ходу выполнения программы давать вразумительный

Показать ответ
Ответ:
sveta465
sveta465
08.10.2020 14:44
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество элементов в массиве:');
  var a:=ReadArrReal('Вводите элементы массива через пробел или Enter',n);
  Writeln('Ввод завершен')
end.

Пример
Количество элементов в массиве: 5
Вводите элементы массива через пробел или Enter 3.5 7 -2.9 0.4 11.345
Ввод завершен
0,0(0 оценок)
Ответ:
ayazhankadyrov24
ayazhankadyrov24
08.10.2020 14:44
Язык не указан, так что напишу на паскале ABC.

const
  maxn = 100;

type
  myarr = array [1..maxn] of integer;

var
  a: myarr;
  n, i: integer;

begin
  writeln('Введите размер массива:');
  readln(n);
  writeln('Введите массив:');
  for i := 1 to n do
    read(a[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота