В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
zokaa112
zokaa112
27.02.2022 16:55 •  Информатика

Составить программу для вычисления среднего арифметического: 2.1; 2.3; 2.5; 2.7; 2.9 для паскаля там где начало: var i,k; integer

Показать ответ
Ответ:
Jannacool
Jannacool
23.02.2020 12:37
PascalABC.NET 3.4.2, сборка 1843 от 24.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger('Размер массива:');

 var k := ReadInteger('Максимальное значение элемента:');

 var a := ArrRandom(n, 0, k);

 a.Println;

 var b := ArrRandom(n, 0, k);

 b.Println;

 var c := a.Zip(b, (p, q)-> p + q).ToArray;

 c.Println;

 k := c.Max;

 var v := ArrFill(k + 1, 0);

 for var i := 0 to c.High do

   v[c[i]] += 1;

 var d := 0;

 for var j := 0 to k do

   for var i := 0 to v[j] - 1 do

   begin

     c[d] := j;

     d += 1

   end;

 c.Println

end.

Размер массива: 15Максимальное значение элемента: 4031 11 31 28 10 30 16 38 24 25 11 38 0 29 3531 36 6 35 15 2 13 34 10 6 37 14 32 31 1062 47 37 63 25 32 29 72 34 31 48 52 32 60 4525 29 31 32 32 34 37 45 47 48 52 60 62 63 72
0,0(0 оценок)
Ответ:
Viktoria120t
Viktoria120t
08.09.2020 16:36
Код

#include <iostream>


using namespace std;


int main(){


   setlocale(LC_ALL, "Russian");


   string s;


   unsigned int yValue = 0, eValue = 0, sValue = 0;


   cout << "Введите строку: ";


   cin >> s;


   for(int i = 0; i < s.length(); i++){


       char t = s[i];


       switch(t){


  /*


  break нужен обязательно, так как после прохождения условия case оно прыгает на следующее,


  а когда в конце оно видит break, то мгновенно обрывают дальнейшие перескоки


  */


           case 'Y': yValue = yValue + 1; break;  

           case 'e': eValue = eValue + 1; break;


           case 's': sValue = sValue + 1; break;


       }


   }


   if((yValue >= 1) && (eValue >= 1) && (sValue >= 1)){


       cout << "Да, все буквы слова 'Yes' содержатся в введённом предложении.";


   }


   else{


       cout << "Нет, не все буквы слова 'Yes' содержатся в введённом предложении.";


   }


   return 0;


}


Проверка

Введите строку: YYah                            

Нет, не все буквы слова 'Yes' содержатся в введённом предложении.



Введите строку: YesYesyesYesyesYes                                        

Да, все буквы слова 'Yes' содержатся в введённом предложении.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота