В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Aelly
Aelly
22.08.2020 08:05 •  Информатика

Составить программу для вычисления суммы k членов ряда ∑_ (n = 1) ^k (x ^ (n) / n), где k определяется из критерия, || Uk | - | Um || <ебселунт, где ебселунт - заранее заданная точность вычисления и m = k + 1. При вводе данных необходимо учитывая то, x может принимать любое значение из допустимого диапазона, который приведен в условии каждой конкретной задачи. Если такой диапазон не указан, то ограничений на значение переменной x нет. При составлении программы использовать рекурсивную функцию для вычисления Um с рекуррентной формулы U_m = U_n * x*( n / (n-1)), m = n + 1 и | x | <1.

Показать ответ
Ответ:
halker249Neekolay
halker249Neekolay
03.01.2022 08:42

program ryazantsev;

var str, newstr: string;

pos,i,k:integer;

begin

newstr:='';

Writeln ('Введите строку с фамилиями');

Readln(str);

for i:=1 to Length(str) do begin

if str[i]=' ' then continue;

if (i=1) or (str[i-1]=' ') then pos:=i

else if (i=Length(str)) or (str[i+1]=' ') then begin

if LowerCase(str[i])=LowerCase(str[pos]) then k:=k+1;

if (i-pos+1) mod 2 <> 0 then newstr:=newstr+Copy(str, pos, i-pos+1)+' '

end

end;

writeln('Количество фамилий начинающихся и заканчивающихся на одну букву: ', k);

writeln('Новая строка: ', newstr)

end.

0,0(0 оценок)
Ответ:
Adventurous
Adventurous
25.05.2021 02:16
#include <iostream>
using namespace std;
struct P
{
    P() = default;
    P(int x, int y)
    {
        this->x = x;
        this->y = y;
    };

    int x;
    int y;
};

int main()
{
    int size;
    cin >> size;
    P *arr = new P[size];
    for (int i = 0; i < size; i++) {
        cin >> arr[i].x;
        cin >> arr[i].y;
    };

    P temp; // временная переменная для обмена элементов местами

              // Сортировка массива пузырьком
    for (int i = 0; i < size - 1; i++) {
        for (int j = 0; j < size - i - 1; j++) {
            if (arr[j].x > arr[j + 1].x) {
                // меняем элементы местами
                temp.x = arr[j].x;
                arr[j].x = arr[j + 1].x;
                arr[j + 1].x = temp.x;
            }
        }
    }

    // Вывод отсортированного массива на экран
    for (int i = 0; i < size; i++) {
        cout << arr[i].x << " ";
    }

    delete[] arr;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота