Составить программу для вычисления выражения: а) при x = 2.36, c = 18.7, d = 6.46 б) если знаменатель равен нулю,на экран нужно выдавать сообщение об ошибке. p.s. там где двоеточия - дробь,там где восклицательные знаки - модуль,и в выражений б) sin(п: 7),и в sin(2п: 7)
Program kyt333;
uses crt;
const
c=18.7;
d=6.46;
var
x,y,a:real;
begin
write('Введите х: '); readln(x);
writeln();
if (abs(x)+d = 0) or (cos(x)=0) then writeln('Знаменатель равен нулю!')
else
begin
y:=(c+d-sin(x)/cos(x))/(abs(x)+d);
a:=5.23+7.6*7.6+sin(pi/7)/sin(2*pi/7)+3.1;
end;
writeln('Результаты:');
writeln('y=',y:8:2); writeln('a=',a:8:2);
end.