Составить программу для вычисления значения функции f(x) на отрезке [a,b]с шагом h.результат представить в виде таблицы,первый столбец которой-значение вргумента,второй-соответствующие значения функции
Компьютер понадобился человеку для более быстрых вычислений, само слово compute переводится с английского как "считать". Затем компьютер использовали и используют для хранения и обработки больших данных.
Я понимаю под значением слова "универсальный" - это то, что компьютер можно использовать как для работы, так и для развлечения, общению и т.п., то есть он заменил множество вещей.
У компьютера очень много профессией, что все их не перечислить. Например, в программировании, бухучете, инженером деле и т.д.
Const Pi=3.1415926598; var c:integer; r,a,b,h:real; begin Writeln('Введите код вычисляемой величины: '); Writeln('1 - длина окружности'); Writeln('2 - площадь круга'); Writeln('3 - объем цилиндра'); Writeln('4 - объем параллелепипеда'); Write('-> '); Read(c); case c of 1: begin Write('Введите радиус окружности: '); Read(r); Writeln('Длина окружности равна ',2*Pi*r) end; 2: begin Write('Введите радиус круга: '); Read(r); Writeln('Площадь круга равна ',Pi*r*r) end; 3: begin Write('Введите радиус и высоту цилиндра: '); Read(r,h); Writeln('Объем цилиндра равен ',Pi*r*r*h) end; 4: begin Write('Введите длину, ширину и высоту параллелепипеда: '); Read(a,b,h); Writeln('Объем параллелепипеда равен ',a*b*h) end end end.
Пример работы Введите код вычисляемой величины: 1 - длина окружности 2 - площадь круга 3 - объем цилиндра 4 - объем параллелепипеда -> 3 Введите радиус и высоту цилиндра: 5 18.3 Объем цилиндра равен 1437.2786418585
Я понимаю под значением слова "универсальный" - это то, что компьютер можно использовать как для работы, так и для развлечения, общению и т.п., то есть он заменил множество вещей.
У компьютера очень много профессией, что все их не перечислить. Например, в программировании, бухучете, инженером деле и т.д.
Pi=3.1415926598;
var
c:integer;
r,a,b,h:real;
begin
Writeln('Введите код вычисляемой величины: ');
Writeln('1 - длина окружности');
Writeln('2 - площадь круга');
Writeln('3 - объем цилиндра');
Writeln('4 - объем параллелепипеда');
Write('-> '); Read(c);
case c of
1: begin
Write('Введите радиус окружности: '); Read(r);
Writeln('Длина окружности равна ',2*Pi*r)
end;
2: begin
Write('Введите радиус круга: '); Read(r);
Writeln('Площадь круга равна ',Pi*r*r)
end;
3: begin
Write('Введите радиус и высоту цилиндра: '); Read(r,h);
Writeln('Объем цилиндра равен ',Pi*r*r*h)
end;
4: begin
Write('Введите длину, ширину и высоту параллелепипеда: '); Read(a,b,h);
Writeln('Объем параллелепипеда равен ',a*b*h)
end
end
end.
Пример работы
Введите код вычисляемой величины:
1 - длина окружности
2 - площадь круга
3 - объем цилиндра
4 - объем параллелепипеда
-> 3
Введите радиус и высоту цилиндра: 5 18.3
Объем цилиндра равен 1437.2786418585