Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
vladimirkotov71
07.05.2023 07:05 •
Информатика
Составить программу для вычисления значения функции f(x)=x*cos(1/x)+2 на отрезке [a,b] с шагом h. результаты представить в виде таблицы (1-ый столбец - значения аргумента, 2- ой -значение функции).
Показать ответ
Ответ:
elenaveruaskina
22.06.2020 17:19
Const
n = 10;
var
a,b,h,x: real;
begin
writeln('a , b , h =');
read(a, b, h);
x := a - h;
writeln('x':n, ' | ', 'y':n);
repeat
x := x + h;
writeln(x:n:3, ' | ', (x * cos(1 / x) + 2):n:3);
until x >= b;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
odminsovet
08.06.2022 22:18
Для питона. ввести два натуральных числа a и b и заполнить массив из 10 элементов случайными числами в диапозоне между a и b(a может быть больше b). пример: пример: введите...
ЛизаНагайцева03
06.11.2020 21:34
Сообщение о том,что ира живёт в квартире № 10 несёт 8 бит информации. сколько квартир в доме?...
AidarSharafutdinov
10.08.2020 08:14
составить программу на языке С#, позволяющую пользователю с меню вычислить значение выражения: (в приложении )Значения переменных n, m, k вводятся пользователем с клавиатуры...
ApuCTokpaT1
21.06.2022 06:20
ОЧЕНЬ Составьте программу, которая реализуетввод с клавиатуры трех произвольныхположительных чисел а, b и c. Возводит вквадрат только нечетные числа, а четныеоставляет без...
жека569
21.06.2022 06:20
Как классифицируют преобразование координат?...
KSeNiYa2800
02.09.2021 05:01
Исполнитель вычислитель умеет выполнять только две команды: умножить на2 и прибавить 1.придумайте для него наиболее короткий план получения из 0 числа 50...
MDI1
15.10.2020 21:06
5. Постройте инфографику на тему достижения робототехники...
youtubeadamchuk
16.05.2022 14:26
3-тапсырма. Жау тылындағы кейіпкерлердің бостандық үшін, болашақ бақыт үшін аянбай алысқан көрінісін өз көзқарасынды білдіре отырып, дамытып жаз....
Vikof
22.11.2022 15:31
Что такое трептих только быстро...
089280ig
22.11.2022 15:31
Дана функция y = x - 2x - 8 . а) Найдите значения функции f (3), f (5). б) Если известно, что график функции проходит через точку (п; 16), найдите п....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n = 10;
var
a,b,h,x: real;
begin
writeln('a , b , h =');
read(a, b, h);
x := a - h;
writeln('x':n, ' | ', 'y':n);
repeat
x := x + h;
writeln(x:n:3, ' | ', (x * cos(1 / x) + 2):n:3);
until x >= b;
end.