В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
апркаерн
апркаерн
13.05.2023 12:48 •  Информатика

Составить программу для вывода на экран произведения трех введенных чисел, если все они не равны нулю. в противном случае вывести на экран их сумму

Показать ответ
Ответ:
vladimer96
vladimer96
22.12.2020 05:08

import java.util.Scanner;

public class Power {

public static void main(String[] args) {

 int a,b,n,i,result;

 Scanner scan = new Scanner(System.in);

 

 System.out.println("a:");

 a = scan.nextInt();

 System.out.println("b:");

 b = scan.nextInt();

 

 for(n=0;n<=b;n++){

  result=1;

  for(i=0;i<n;i++){

   result=result*a;

  }

  System.out.println(a+"^"+n+"="+result);

 }

 

 scan.close();

 

}

}

Объяснение:

Программа вычисляет значения a в степени n,где n идет от 0 до b включительно.Краткий алгоритм программы:Импортируем Scanner(для ввода);В методе main создаем 5 переменных типа int и один объект класса Scanner;Вводим числа a,b;Запускаем "двойной" цикл;В цикле вычисляем a в степени n и выводим результат;Закрываем Scanner;
0,0(0 оценок)
Ответ:
TheAlexKillGame
TheAlexKillGame
13.11.2022 08:14
1)type ta=array[1..30,1..10] of Integer;

var ma:ta;
i,k,j:integer;

procedure SearchAndInc(ma:ta; var k:integer);
var i,j:integer;
begin;
for i:=1 to 30 do
 for j:=1 to 10 do
  if (i+j) mod 5=0 then k:=k+ma[i,j];
end;

begin;
randomize;
writeln('Matrix:');
for i:=1 to 30 do
 begin;
  writeln;
   for j:=1 to 10 do
    begin;
     ma[i,j]:=random(50);
     write(ma[i,j]:4);
    end;
 end;
SearchAndInc(ma,k);
writeln;
writeln('Result:',k);
end.

2)type
 ta=array[1..20,1..5] of Integer;

 procedure Minim(ma:ta;var mini,minj:integer);
var i,j,min:integer;
begin;
min:=2147483647;
for i:=1 to 20 do
 begin;
  for j:=1 to 5 do
   begin;
    if min>ma[i,j] then
      begin;
        min:=ma[i,j];
        mini:=i;
        minj:=j;
      end;
    end;
 end;
end;

var ma:ta;
i,j,c,mini,minj,min:integer;
begin;
randomize;
writeln('Matrix:');
for i:=1 to 20 do
 begin;
  writeln;
   for j:=1 to 5 do
    begin;
     ma[i,j]:=random(50);
     write(ma[i,j]:4);
    end;
 end;
Minim(ma,mini,minj);
writeln;
c:=ma[1,2];
ma[1,2]:=ma[mini,minj];
ma[mini,minj]:=c;
writeln('Final matrix:');
for i:=1 to 20 do
 begin;
  writeln;
   for j:=1 to 5 do
    write(ma[i,j]:4);
 end;
writeln;
writeln('Min:',min);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота