В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Aslanov1999
Aslanov1999
25.07.2022 13:05 •  Информатика

Составить программу: если число четное, то возвести его в квадрат, иначе умножить его на 7 тремя блок-схема
2. алгоритмический язык
3. Pascal.

Показать ответ
Ответ:
нуралик
нуралик
13.10.2020 14:16

1) блок-схема прикреплена

2) Алг. язык: (Тут я без понятия, правильно или нет)

нач цел x

ввод x

если x/2=0

то вывод x^2

иначе вывод x*7

кон

3) Pascal:

var x:integer;

begin

 writeln('Введите число');

 readln(x);

 if (x mod 2) = 0 then writeln('Число четное, его квадрат: ' + x**2)

 else writeln('Число НЕ четное: ' + x*7);

end.


Составить программу: если число четное, то возвести его в квадрат, иначе умножить его на 7 тремя бло
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота