В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
aselm94
aselm94
01.04.2020 23:07 •  Информатика

Составить программу, формирующую одномерный массив, состоящий из n вещественных элементов. преобразовать массив таким образом, чтобы сначала располагались все отрицательные элементы, а потом – все положительные (элементы, равные 0, считать положительными). найти индекс максимального элемента массива. вычислить среднее арифметическое всех нечетных по порядку элементов массива.

Показать ответ
Ответ:
mashadadihf
mashadadihf
06.10.2020 14:15
// PascalABC.NET 3.2, сборка 1492 от 03.07.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  a:=(a.Where(x->x<0)+a.Where(x->x>=0)).ToArray; a.Println;
  Writeln('Номер максимального элемента: ',a.IndexMax+1);
  Writeln('Среднее арифметическое нечетных по порядку: ',
      a.Where((x,i)->i.IsEven).Average)
end.

Пример
n= 15
18 -24 31 -4 -13 -45 24 -25 34 -42 -6 36 -50 40 -15
-24 -4 -13 -45 -25 -42 -6 -50 -15 18 31 24 34 36 40
Номер максимального элемента: 15
Среднее арифметическое нечетных по порядку: 2.75
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота