В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Arsen00628
Arsen00628
01.01.2023 20:10 •  Информатика

Составить программу и блок-схему для найти полную энергию самолета массой m на высоте h со скоростью v

Показать ответ
Ответ:
ruzhejnickovan
ruzhejnickovan
19.06.2020 21:58

10) (Первый скриншот):

static void Main(string[] args)

       {

           int N = 0;

           int count = 0;

           double srednekv = 0;

           Console.Write("Введите размерность вектора: ");

           N = Convert.ToInt32(Console.ReadLine());

           int count2 = N;

           int[] A = new int[N];

           Random rnd = new Random();

           for (int i = 0; i < N; i++)

           {

               A[i] = rnd.Next(0, 10);

           }

           Console.WriteLine();

           Console.Write("Первоначальный вектор А: ");

           for (int i = 0; i < N; i++)

           {

               Console.Write(String.Format("{0,3}", A[i]));

           }

           for (int i = 0; i < N; i++)

           {

               srednekv += Math.Pow(A[i], 2);

               if (A[i] != 0)

               {

                   int memory = A[count];

                   A[count] = A[i];

                   A[i] = memory;

                   count++;

               }

           }

           for (int i = 0; i < N; i++)

           {

               if (A[i] == 0)

               {

                   int memory = A[count2 - 1];

                   A[count2 - 1] = A[i];

                   A[i] = memory;

                   count2--;

               }

           }

           Console.WriteLine();

           Console.WriteLine();

           Console.Write("Изменённый вектор А: ");

           for (int i = 0; i < N; i++)

           {

               Console.Write(String.Format("{0,3}", A[i]));

           }

           Console.WriteLine();

           Console.WriteLine();

           Console.WriteLine("Среднеквадратичное элементов вектора = {0}", srednekv/N);

           Console.ReadKey();

       }

7) (Второй скриншот):

static void Main(string[] args)

       {

           int N = 5;

           double[,] C = new double[N, N];

           double sumGlav = 0;

           double sumPoboch = 0;

           Random rnd = new Random();

           for (int i = 0; i < N; i++)

           {

               for (int j = 0; j < N; j++)

               {

                   C[i, j] = rnd.Next(0, 10);

               }

           }

           for (int i = 0; i < N; i++)

           {

               for (int j = 0; j < N; j++)

               {

                   if (i==j)

                   {

                       sumGlav += C[i, j];

                   }

                   if (i + j == N - 1)

                   {

                       sumPoboch += C[i, j];

                   }

               }

           }

           Console.WriteLine();

           Console.Write("Массив: ");

           Console.WriteLine();

           for (int i = 0; i < N; i++)

           {

               for (int j = 0; j < N; j++)

               {

                   Console.Write(String.Format("{0,3}", C[i, j]));

               }

               Console.WriteLine();

           }

           Console.WriteLine("Сумма элементов главной диагонали = {0}", sumGlav);

           Console.WriteLine("Сумма элементов побочной диагонали = {0}", sumPoboch);

           Console.ReadKey();

       }

Объяснение:

В первом - просто ввести размерность вектора, во втором задании он по условию уже задан как 5x5.

0,0(0 оценок)
Ответ:
Intagul
Intagul
13.11.2021 02:12
Я вижу 16-ричную систему. Но тогда в подсчетах ошибка. 
В 16 системе А -10, В - 11 С - 12, D - 13, Е - 14 F - 15
D5 = 5*16^0 + D*16^1 = 5+13*16 = 213(в десятичной)
1A = 1*16^1 + A*16^0 = 16+10 = 26 (в десятичной)
BA = B*16^1 + A* 16^0 = 11*16+10 = 186
Если отнять эти числа в 10-й системе, то выходит 213 - 26 - 187.
Поэтому в задаче или у тебя в записи ошибка. Разность в 16-й системе, т.е количество сказаок равна не ВА, а ВВ, тогда все получится.
В*16^0+B*16^1 = 11 = 16*11 = 187
И тогда ответ - 16-ричная ситстема счисления.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота