Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
elag
17.08.2020 00:04 •
Информатика
Составить программу и блок-схему для решения . решение каждой сопроводить пояснительной запиской с описанием используемых в конструкций языка си. a[n] найти среднее элементов массива а . ai > 0; n=10
Показать ответ
Ответ:
ddurua
03.10.2020 03:36
#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int n;
float x=1,y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
x *= mass[i];
k++;
}
y = pow(x, 1/k);
cout << " y= " <<y;
system("pause");
}
0,0
(0 оценок)
Популярные вопросы: Информатика
almaz108
05.05.2022 13:28
Ре 1. Составьте программу, вычисляющую произведение двухчисел.2. Составьте программу, вычисляющую сумму двузначныхили многозначных чисел.3. Составьте программу, вычисляющую среднее...
oleg022
29.04.2022 06:04
Сколько раз выполнится тело цикла в следующем программном коде int n=5; for (int i=0; i for (int j=1; j for (int k=1; k =n; k++) { // тело цикла }...
aidana70
27.08.2022 18:26
2. Как удаляем переносы? А) Нажимаем два раза левую кнопку мышиБ) Можно удалить автоматическую расстановку переносов и любой перенос, вставленный вручную (мягкие переносы и неразрывные...
mrpixkaGogar
29.04.2020 18:45
Қасиеттері бойынша элементті іздеу Код үзіндісін орындаудың дұрыс нәтижесін анықта.color=[ blue , gray , red , fuchsia , pink , gold , orange ]print (color.index( gold )) gold...
huhttt
12.12.2022 06:27
Возрождение и взлёт. Свой собственный путь. 3-я Годовщина что ты с нами. Тебя ждут новые режимы и награды! Сайт Free Fire:https://ffshare.garena.com/?region=RU〈=ru&action=reunion&uid=2645743653....
ххх87
17.10.2022 19:22
Верно ли утверждение, что тип данных характеризует одновременно множество допустимых значений, которые могут принимать данные,принадлежащие к этому типу?неверноверно...
karicristle313
06.06.2021 02:28
Найдите общие и отличительные черты команд цикла.Команды цикловОбщие черты ОтличительныечертыЦикл со счётчикомЦикл с условиемЦикл без условия МНЕ ЧЕРЕЗ ЧАС НА ДР...
Ертилеу
20.02.2021 11:39
Надо опредилить функций этих ДАЮ 25-Б...
nikita200310266xcute
10.04.2022 10:38
3-тапсырма Айдын,Санжар және Асқар үшеуі балық аулауға барды.Балалар сәйкесінше саны R,L және M болатын балықтар аулады.Достар аулаған балықтардың тең бөліп алса,оларға неше балықтан...
marybyl86
28.08.2022 11:12
УКР - Як налаштувати дію над об єктом? Які бувають дії та на які об єкти їх можно налаштувати. РУС - Как настроить действие над объектом? Какие бывают действия и на какие объекты...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <cmath>
using namespace std;
void main()
{
int n;
float x=1,y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
x *= mass[i];
k++;
}
y = pow(x, 1/k);
cout << " y= " <<y;
system("pause");
}