В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
cernyshova
cernyshova
08.02.2020 07:17 •  Информатика

Составить программу и блок - схему для сравнения роста двух девочек. напечатайте имя той, которая выше.

Показать ответ
Ответ:
Wonderfulgirl30
Wonderfulgirl30
17.07.2020 10:47
Var
  h1,h2:integer;
  n1,n2:string;
begin
  Write('Введите имя первой девочки: '); Readln(n1);
  Write('Введите рост первой девочки: '); Readln(h1);
  Write('Введите имя второй девочки: '); Readln(n2);
  Write('Введите рост второй девочки: '); Readln(h2);
  if h1>h2 then Writeln(n1,' выше, чем ',n2)
  else if h2>h1 then Writeln(n2,' выше, чем ',n1)
  else Writeln(n1,' и ',n2,' одного роста')
end.

Тестовое решение:
Введите имя первой девочки: Наташа
Введите рост первой девочки: 163
Введите имя второй девочки: Даша
Введите рост второй девочки: 167
Даша выше, чем Наташа

Блок-схема дана во вложении. Блоки ввода вывода упрощены в связи с невозможностью (и ненужностью) точно отобразить вид ввода и вывода.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота