В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
egorkashoshin0
egorkashoshin0
28.04.2020 22:46 •  Информатика

Составить программу и блок схему нахождения а)суммы элементов массива С[1..30] б)количества элементов массива D[1..2], принадлежащих промежутку [1;15]​


Составить программу и блок схему нахождения а)суммы элементов массива С[1..30] б)количества элементо

Показать ответ
Ответ:
Арина11841
Арина11841
28.06.2022 19:21
Var
a:array[1..5] of integer;
i,Max,c,n,f:integer;
 procedure ho;
 begin
       if a[i]>Max then
        begin
         Max:=a[i];
         c:=i;
        end;
 end;

 begin
   for i:=1 to 5 do
     begin
       a[i]:= random(15)+2;
       write(a[i],' ');
     end;
     Max:=a[1];
     c:=1;
     for i:=1 to 5 do
      ho;
      writeln;
      writeln('Максимум: ',max);
       f:=c;
                    if f=1 then
                    begin
                     max:=a[2];
                     for i:=2 to 5 do
                      ho;
                      writeln('Вторичный максимум: ',max);                                            exit;
                    end;       
                           if f<5 then
                      begin
                          Max:=a[f+1];
                          for i:=f+1 to 5 do
                          ho;
                          n:=max;
                       end;
                    if f>1 then
                      begin
                          Max:=a[1];
                          c:=f;
                          for i:=1 to c-1 do
                          ho;
                          if max>n then
                          writeln('Вторичный максимумì: ',max);
                          if max<n then
                          writeln('Вторичный максимум: ',n); 
                                               end;
   end.
0,0(0 оценок)
Ответ:
Клеу
Клеу
28.12.2020 04:48
#include <iostream> #include <vector> #include <algorithm> #include <numeric> int main() { std::vector<int> arrayOfDummies; for (char answer{0};;) {  std::cout << "You want to enter a rating?" << std::endl;  std::cin >> answer;  if (int value{0}; answer == 'y')  {   std::cout << "Enter rating:";   std::cin >> value;   arrayOfDummies.push_back(value);  }  else break; } std::cout << "Average: " << std::accumulate(arrayOfDummies.begin(), arrayOfDummies.end(), 0) /    arrayOfDummies.size() << std::endl; }
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота