Составить программу и её блок-схему используя одномерные массивы: Дано одномерный массив А, состоящий из N элементов. Посчитать максимальное количество подряд нулей. (Pascal)
var A: array [1..10] of integer; i, j, n, temp: integer;
begin randomize(); n := 10; for i := 1 to n do begin A[i] := random(100); write(A[i], ' '); end;
for j := 1 to n - 1 do begin for i := 1 to n - j do begin if a[i] mod 10 < a[i + 1] mod 10 then begin temp := a[i]; a[i] := a[i + 1]; a[i + 1] := temp; end; end; end;
writeln(); for i := 1 to n do write(A[i], ' '); end.
Программа "Буква Т"
нач
шаг
шаг
шаг
шаг
поворот
прыжок
прыжок
поворот
шаг
шаг
шаг
шаг
кон
Стрелочка будет находиться наверху, смотреть вправо
Программа "Буква Н"
нач
поворот
поворот
поворот
шаг
шаг
шаг
шаг
поворот
поворот
прыжок
прыжок
поворот
поворот
поворот
шаг
поворот
прыжок
прыжок
поворот
поворот
шаг
шаг
шаг
шаг
кон
Стрелочка находится наверху, смотрит справо
var
A: array [1..10] of integer;
i, j, n, temp: integer;
begin
randomize();
n := 10;
for i := 1 to n do
begin
A[i] := random(100);
write(A[i], ' ');
end;
for j := 1 to n - 1 do
begin
for i := 1 to n - j do
begin
if a[i] mod 10 < a[i + 1] mod 10 then begin
temp := a[i];
a[i] := a[i + 1];
a[i + 1] := temp;
end;
end;
end;
writeln();
for i := 1 to n do
write(A[i], ' ');
end.