В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
СоваИгорь
СоваИгорь
06.08.2022 07:59 •  Информатика

Составить программу и определить, принадлежит ли точка с координатами (х, у) кругу с r=1 и центром в начале координат о(0,0).
уравнение окружности
х2 + у2 = r2
if х * х + у * у < = r * r
then writeln (‘точка принадлежит кругу’) else
writeln (‘точка не принадлежит кругу’);

Показать ответ
Ответ:
Annnnnnnnnnнnna
Annnnnnnnnnнnna
24.08.2022 01:17
Для того что бы округлить нужно использовать "=ОКРУГЛ" данная команда округляет число до указанного количества десятичных разрядов, цифр после запятой. (что бы округлить сумму нужно записывать количество десятичных разрядов в конце выражения). Пример:«=ОКРУГЛ(выражение);число)»

Дано:

Математическое выражение:
«(89+75)−2(72:(3+7))»

Найти:
Значение выражения и округлить его в MS Ecxel.

Формула (Её нужно ввести в окошко Excel и нажать "Enter"):
«=ОКРУГЛ((89+75)-2*(72/(3+7));2)»

ответ:
149,6

(До сотых программа округлить не может, ибо число имеет только десятые в ответе)

Далее скриншот, и файл Excel в котором формула и сам ответ.


Вычисли значение выражения в ms excel: (89+75)−2(72: (3+ (ответ округли до сотых)
0,0(0 оценок)
Ответ:
StEInN2
StEInN2
24.02.2021 00:04
Const n=8;
var x : array[1..n] of real;
   i : integer; min : real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
  x[i]:=20*random-10;
  write(x[i]:6:2,' ');     
 end;
 writeln;
min:=x[1];
for i:=2 to n do
 if x[i] < min then min:=x[i];
writeln('min=',min:6:2);
for i:=1 to n do
 if x[i]<0 then x[i]:=min;
writeln('Измененный массив:');
for i:=1 to n do write(x[i]:6:2,' ');
end.

Пример:
Исходный массив:
 -7.84  -9.97   7.00  -8.26  -7.71  -3.88   7.59  -2.32 
min= -9.97
Измененный массив:
 -9.97  -9.97   7.00  -9.97  -9.97  -9.97   7.59  -9.97 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота