В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
KeeRuSha
KeeRuSha
11.08.2020 16:40 •  Информатика

Составить программу, используя двумерный массив: Рассчитать сумму положительных нечетных элементов матрицы​
(Pascal)

Показать ответ
Ответ:
GabriellaKiM
GabriellaKiM
27.02.2021 00:26

var

 a: array[,] of integer;

 m, n, i, j, sum: integer;

begin

 Write('Введите размер матрицы M и N: '); ReadLn(m, n);

 SetLength(a, m, n);

 randomize;

 WriteLn('Массив:');

 for i := 0 to m - 1 do

 begin  

   for j := 0 to n - 1 do

   begin

     a[i, j] := random(200) - 100;

     Write(a[i, j]:4);

     if (a[i, j] > 0) and (a[i, j] mod 2 = 1) then sum := sum + a[i, j];

   end;

   WriteLn;

 end;

 WriteLn('Сумма положительных нечетных элементов матрицы равна ', sum);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота