В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
СерёгаД
СерёгаД
08.03.2020 17:34 •  Информатика

Составить программу «календарь xx столетия» , которая определяет день недели любого дня xx-го столетия. по введенному значению 1, 2, 3 вычисляет 1.номер дня недели по формуле, где d- день, м-месяц, g-год: •s=[(12-m)/10] •k=[(g-1900-s)*365,25]+[(m+12*s-2)*30,59]+d+29 •n=k-7[k/7] (n-вычисляется от 0-воскресенье до 6-суббота, []-целая часть) 2.день недели по его номеру 3.выход

Показать ответ
Ответ:
676751
676751
13.08.2020 15:55
// PascalABC.NET 3.0, сборка 1128
begin
  var D:=ReadInteger('Номер дня (1-31)');
  var M:=ReadInteger('Номер месяца (1-12)');
  var G:=ReadInteger('Номер года (1900-1999)');
  var S:=(12-M) div 10;
  var K:=Trunc(Int((G-1900-S)*365.25)+Int((M+12*S-2)*30.59)+D+29);
  var N:=K mod 7;
  case N of
  0:Writeln('Воскресенье');
  1:Writeln('Понедельник');
  2:Writeln('Вторник');
  3:Writeln('Среда');
  4:Writeln('Четверг');
  5:Writeln('Пятница');
  6:Writeln('Суббота')
  end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота