В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
morfikk
morfikk
02.03.2021 02:16 •  Информатика

Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию. ввод чисел заканчивается нажатием клавиши 0. протокол работы программы: выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 1 введите два числа: 15 16 ответ: 15+16=31 выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 3 введите два числа: 5 8 ответ: 5*8=40 выберите тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, 0 - выход. 0 пока!

Показать ответ
Ответ:
Regina2203021
Regina2203021
05.10.2020 22:14
Var a,b,c,x:real;
begin 
repeat 
writeln('Введите тип арифм. операции (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - остановить программу'); 
readln(x); 
if x=1  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a+b;   
writeln('ответ: ',c);   
end; 
if x=2  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a-b;   
writeln('ответ: ',c);   
end; 
if x=3  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a*b;   
writeln('ответ: ',c);   
end; 
if x=4  then   begin   
writeln('Введите 2 числа');   
readln(a,b);   
c:=a/b;   
writeln('ответ: ',c);   
end; 
if x=0 then writeln('Пока!'); 
until x=0;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота