В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
aleksaprincessa
aleksaprincessa
26.12.2020 16:24 •  Информатика

Составить программу которая будет вычислять значение выражения у = cosx + cosx^2 + cosx^3 + + cosx^n, используя процедуру вычисляющую x в n степени

Показать ответ
Ответ:
irishkaevdokimova14
irishkaevdokimova14
06.10.2020 00:00
Процедурой:

// Возводит действилельное число x в целую степень n
Procedure Pow(Const X:real; Const n:integer; Var St:real);
Var i:integer;
Begin
St:=1;
For i:= 1 to n do
    St:=St*x;
End;

Var
   x,y,St:real;
   n:integer;
Begin
y:=0;
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
For n:= 1 to n do
    Begin
    Pow(x,n,St);
    y:=y+Cos(St);
    End;
WriteLn('y = ',y);
End.

Функцией:

// Возводит действилельное число x в целую степень n
Function Pow(Const X:real; Const n:integer):real;
Var i:integer;
Begin
result:=1;
For i:= 1 to n do
    result:=result*x;
End;
Var
   x,y:real;
   n:integer;
Begin
y:=0;
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
For n:= 1 to n do
    y:=y+Cos(Pow(x,n));
WriteLn('y = ',y);
End.

Циклом:

Var
   x,y,St:real;
   n:integer;
Begin
y:=0;
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
St:=1;
For n:= 1 to n do
    Begin
    St:=St*x;
    y:=y+Cos(St);
    End;
WriteLn('y = ',y);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота