В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
marrycat1
marrycat1
04.02.2023 18:07 •  Информатика

Составить программу ,которая будет выдавать последовательность квадратов натуральных чисел от 1 до n, где n вводится с экрана.заранее

Показать ответ
Ответ:
ayzilyamannano
ayzilyamannano
08.10.2020 06:39
PascalABC.NET 3.3.5, сборка 1640 от 17.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  1.To(ReadInteger('n=')).Select(t->t*t).Println
end.

Пример
n= 30
1 4 9 16 25 36 49 64 81 100 121 144 169 196 225 256 289 324 361 400 441 484 529 576 625 676 729 784 841 900
0,0(0 оценок)
Ответ:
zak8rbayramovp0akso
zak8rbayramovp0akso
08.10.2020 06:39
var x,n: integer;
begin
write('n = ');
readln(n);
     x := 1;
while sqr(x) < n do begin write(sqr(x),' ');
         x := x + 1 end;  
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота