Составить программу, которая бы находила количество и произведение отрицательных элементов в каждом столбце матрицы и выдавала их на экран. Двухмерный массив заполнить случайным образом в диапазоне [-40;40], размерность массива 4x3
Uses crt; const q=1000;var a:array[1..q,1..q]of integer; m,n,i,j,c,k,buf:integer; b:array[1..q]of integer; begin writeln('n,m ?') ; readln(n,m); writeln('как заполнять матрицу ?'); writeln(' Нажмите 1 при датчика, 2 - ввод с клавиатуры'); {выбор действия при заполнении} readln(c); case c of 1:for i:=1 to n do begin for j:=1 to m do begin a[i,j]:=random(100); write(a[i,j]:4); end; writeln; end; 2: begin for i:=1 to n do begin for j:=1 to m do readln(a[i,j]); end; clrscr; for i:=1 to n do begin for j:=1 to m do write(a[i,j]:4); writeln; end; end; end; writeln('формирование массива'); for i:=2 to n do begin if i mod 2=0 then for j:=1 to m do if a[i,j]>2 then begin k:=k+1; b[k]:=a[i,j]; end; end; writeln; for i:=1 to k do write(b[i]:4); writeln; {сортировка} for i:=1 to k -1 do for j:=i+1 to k do if b[i]<b[j]then begin buf:=b[i]; b[i]:=b[j]; b[j]:=buf; end; {вывод массива} for i:=1 to k do write(b[i]:4); end.
program Slova; var s: string; r,i:integer; begin writeln('Введите ваше предложение'); readln(s); s:=s+' '; for i:=1 to length(s)-1 do if (s<>' ') and (s[i+1]=' ') then r:=r+1; writeln('В предложении ',r, ' слов. '); readln; end.
Какая буква встречается чаще
Program Bykv; Var s:String; i,k1,k2:byte; Begin write('Введите строку: ');readln(s); For i:=2 to Length(s)-1 do if s[i]=s[1] then inc(k1) else if s[i]=s[Length(s)] then inc(k2); writeln('Первая буква встречается ',k1); writeln('Последняя буква встречается ',k2); writeln('Вывод:'); if k1>k2 then writeln('Первая буква встречается чаще') else if k1<k2 then writeln('Последняя буква чаще') else writeln('Одинаково'); readln; End.
Изменить слово петя на иван в строке
program test; var s,t,z,p:string;j:integer; begin writeln('Введите ваше предложение'); readln(s); write('Введите слово которое хотите заменить: '); readln(t); write('Введите замену слову: ', t, ' <> '); readln(z); if pos(t,s)<>0 then j:=pos(t,s); p:=copy(s,1,j-1); p:=p+z; p:=p+copy(s,j+length(t),length(s)); writeln(p); readln; end.
const
q=1000;var
a:array[1..q,1..q]of integer;
m,n,i,j,c,k,buf:integer;
b:array[1..q]of integer;
begin
writeln('n,m ?') ;
readln(n,m);
writeln('как заполнять матрицу ?');
writeln(' Нажмите 1 при датчика, 2 - ввод с клавиатуры');
{выбор действия при заполнении}
readln(c);
case c of
1:for i:=1 to n do
begin
for j:=1 to m do
begin
a[i,j]:=random(100);
write(a[i,j]:4);
end;
writeln;
end;
2:
begin
for i:=1 to n do
begin
for j:=1 to m do
readln(a[i,j]);
end;
clrscr;
for i:=1 to n do
begin
for j:=1 to m do
write(a[i,j]:4);
writeln;
end;
end;
end;
writeln('формирование массива');
for i:=2 to n do
begin
if i mod 2=0 then
for j:=1 to m do
if a[i,j]>2 then
begin
k:=k+1;
b[k]:=a[i,j];
end;
end;
writeln;
for i:=1 to k do
write(b[i]:4);
writeln;
{сортировка}
for i:=1 to k -1 do
for j:=i+1 to k do
if b[i]<b[j]then
begin
buf:=b[i];
b[i]:=b[j];
b[j]:=buf;
end;
{вывод массива}
for i:=1 to k do
write(b[i]:4);
end.
program Slova;
var
s: string;
r,i:integer;
begin
writeln('Введите ваше предложение');
readln(s);
s:=s+' ';
for i:=1 to length(s)-1 do
if (s<>' ') and (s[i+1]=' ') then
r:=r+1;
writeln('В предложении ',r, ' слов. ');
readln;
end.
Какая буква встречается чаще
Program Bykv;
Var s:String;
i,k1,k2:byte;
Begin
write('Введите строку: ');readln(s);
For i:=2 to Length(s)-1 do
if s[i]=s[1] then inc(k1)
else if s[i]=s[Length(s)] then inc(k2);
writeln('Первая буква встречается ',k1);
writeln('Последняя буква встречается ',k2);
writeln('Вывод:');
if k1>k2 then writeln('Первая буква встречается чаще')
else if k1<k2 then
writeln('Последняя буква чаще')
else writeln('Одинаково');
readln;
End.
Изменить слово петя на иван в строке
program test;
var s,t,z,p:string;j:integer;
begin
writeln('Введите ваше предложение');
readln(s);
write('Введите слово которое хотите заменить: ');
readln(t);
write('Введите замену слову: ', t, ' <> ');
readln(z);
if pos(t,s)<>0 then
j:=pos(t,s);
p:=copy(s,1,j-1);
p:=p+z;
p:=p+copy(s,j+length(t),length(s));
writeln(p);
readln;
end.