В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
apzjxmskaposjxhdh
apzjxmskaposjxhdh
18.09.2021 13:46 •  Информатика

составить программу, которая формирует массив из 10 случайных целых чисел, принадлежит промежутку [0; 12], выводит на экран исходный массив, затем преобразовывает его, увеличивая чётные значения элементов на 10, и выводит на экран преобразованный массив

Показать ответ
Ответ:
милана59
милана59
01.01.2022 12:25

Программа:

Pascal:

var

 arr: array[1..10] of integer;

 i: integer;

begin

 for i := 1 to 10 do arr[i] := random(0,12);

 writeln(arr);

 for i := 1 to 10 do if arr[i] mod 2 = 0 then arr[i] := arr[i] + 10;

 writeln(arr);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота