В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу которая формирует массив из 15 случайных целых чисел из отрезка от -10 до 10. на экран вывести исходный массив и найденный результат. а) найти среднее арифметическое всех элементов массива. б) вычеслить среднее арифметическое положительных (отрицательных) элементов массива.

Показать ответ
Ответ:
MashimaHiro
MashimaHiro
01.10.2020 13:04
Var
a: array [1..15] of integer;
avg, avgpol, avgotr: real;
i, k1, k2: byte;
begin 
avg := 0; avgpol := 0; avgotr := 0; 
writeln('Massiv:'); 
Randomize; 
for i:=1 to 15 do 
begin 
a[i]:=random(20)-10; 
write(a[i], ' '); 
avg:=avg + a[i]; 
if a[i] > 0 then     
begin       
avgpol := avgpol + a[i];       
inc(k1);     
end; 
if a[i] < 0 then     
begin       
avgotr := avgotr + a[i];       
inc(k2);     
end; 
end; 
avg:=avg/15; 
avgpol:= avgpol/k1; 
avgotr:= avgotr/k2; 
writeln; 
writeln('Srednee massiva = ', avg:3:2); 
writeln('Srednee polozh. elementov = ', avgpol:3:2); 
writeln('Srednee otric. elementov = ', avgotr:3:2); 
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота