В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Horosh2545
Horosh2545
19.03.2020 11:29 •  Информатика

Составить программу, которая формирует массив из 5 случайных чисел от -10 до 15. а) найти элементы равные 1. б) найти индекс нечетных элементов. в) найти количество положительных элементов.

Показать ответ
Ответ:
Malajazaika
Malajazaika
06.08.2020 21:52
Const n=5;
var a : array[1..n] of integer;
     k,i : integer;
begin
Randomize;
 for i:=1 to n do
 begin
  a[i]:=random(26)-10;
  write(a[i],' ');
 end;
writeln;
 writeln('элементы равные 1 имеют номера:');
for i:=1 to n do if a[i]=1 then write(i:3);
writeln;
writeln('индексы нечетных элементов:');
for i:=1 to n do if a[i] mod 2<>0 then write(i:3);
writeln;
k:=0;
for i:=1 to n do if a[i]>0 then k:=k+1;
writeln('количество положительных элементов=',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота