В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
alua070707
alua070707
13.02.2021 08:56 •  Информатика

Составить программу, которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и выводит на экран в одну строчку исходный массив, а во вторую строчку все элементы с четными значениями.

Показать ответ
Ответ:
star666
star666
09.10.2020 12:49

#include <stdlib.h>

#include <time.h>

#include <iostream>

using namespace std;

#define N 16

void main()

{

   int randomNumbers[N];

   srand(time(NULL));

   for (int i = 0;i < N; i++)

   {

       randomNumbers[i] = rand() % 40 - 20;

   }

   for (int i = 0; i < N; i++)

   {

       cout << randomNumbers[i] << "  ";

   }

   cout << endl << endl;

   for (int i = 0; i < N; i++)

   {

       if (randomNumbers[i] % 2 == 0)

       {

       cout << randomNumbers[i] << "  ";

       }

   }

   cout << endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота