В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dmitriidimaro
dmitriidimaro
18.10.2020 06:56 •  Информатика

Составить программу которая формирует массив из16 элементов случайных чисел от -20 до 20 и находит элементы с нулевыми значениями

Показать ответ
Ответ:
demid13123456789
demid13123456789
23.05.2020 18:39

Program g;
Var
A, B : Integer;
N : Integer;
S : Integer;
z:array[0..16] of integer;
i : Integer;
v:integer;
Begin
A:=(-20);
B:=20 ;
N:=16 ;
For i := 1 To N Do
Begin
S := Trunc(Random(B-A)+A);
WriteLn (i:2,'-е случайное число:',S:4);
End;
begin
writeln('Індексы элементов кратных 3:');
for v:=0 to 16 do begin
z[v]:=random(40)-20;
if z[v] mod 3 = 0 then write(v, ' ')
end;
end;
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота