В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Nikita45Russia
Nikita45Russia
24.12.2022 03:22 •  Информатика

Составить программу ,которая формирует массив ,содержащий 12 случайных целых чисел ,принадлежащий промежутку [-7; 10],и подсчитывает кол-во всех отрицательный чисел

Показать ответ
Ответ:
bvoznyk69
bvoznyk69
13.07.2020 07:24
#include <iostream>
#include <stdlib.h>      
#include <time.h>       

int main()
{
  srand(time(NULL));

  int a[12];
  int s = 0;
  for (int i = 0; i < 12; ++i){
    a[i] = rand() % 18 - 7;
    if (a[i] < 0) s++;
  }
  std::cout << s;
   return 0;
}
0,0(0 оценок)
Ответ:
aaaaaaaahhh
aaaaaaaahhh
13.07.2020 07:24
Паскаль:
var i,t:integer;
    a:array[1..12] of integer;
begin  randomize;
  for i := 1 to 12 do begin
    a[i] := round( random(17)-7 );
    write(a[i]:3);
  end;
  t := 0;
  for i := 1 to 12 do
    if a[i] < 0 then
      inc(t);
  writeln;
  writeln(t);
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота