В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
диас161
диас161
11.04.2020 12:48 •  Информатика

Составить программу,которая формирует список l, включив в него по одному разу элементы,которые входят одновременно в оба списка l1 и l2. pascal abc.net

Показать ответ
Ответ:
OMG1234567890
OMG1234567890
03.10.2020 01:32
// PascalABC.NET 3.0, сборка 1088
begin
  var L1:=new List<integer>;
  L1.AddRange(SeqRandom(15,-20,20));
  Writeln('Список L1'); Writeln(L1);
  var L2:=new List<integer>;
  L2.AddRange(SeqRandom(10,-5,40));
  Writeln('Список L2'); Writeln(L2);
  var L:=new List<integer>;
  L.AddRange(L1.Intersect(L2).Distinct);
  Writeln('Список L'); Writeln(L);
end.

Тестовое решение:
Список L1
[8,7,-13,0,12,-1,3,5,-15,13,18,-10,16,14,-1]
Список L2
[31,37,25,13,2,14,5,8,10,34]
Список L
[8,5,13,14]
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота