В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
snezhana9197
snezhana9197
09.04.2020 20:38 •  Информатика

Составить программу, которая определяет возможность существования
треугольника по трем введенным сторонам. Треугольник существует только
тогда, когда сумма любых двух его сторон больше третьей.

Показать ответ
Ответ:
OlegNovikov212
OlegNovikov212
14.10.2020 19:39

var a, b, c: integer;

 

begin

   write (' Длины сторон: ');

   readln (a,b,c);

 

   if (a < b+c) and (b < a+c) and (c < a+b) then

       writeln ('Треугольник существует.')

   else

       writeln ('Треугольник не существует.');

 

readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота