В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
1Harius1
1Harius1
12.10.2022 09:34 •  Информатика

Составить программу, которая переворачивает слово наоборот, если оно состоит из 4 букв. Паскаль

Показать ответ
Ответ:
ник5041
ник5041
15.03.2021 17:33

var str:string;

begin

 write('Введите слово: ');

 readln(str);

 var reverse_str:= '';

 if str.Length = 4 then begin

                           for var i:= str.Length downto 1 do

                             reverse_str:= reverse_str + str[i];

                           writeln(reverse_str);

                        end

                   else writeln('Слово состоит НЕ из 4 букв');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота