В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
zubtan1951
zubtan1951
05.01.2020 13:37 •  Информатика

Составить программу, которая по номеру дня в месяце печатает день недели. Считаем, что 1–е число месяца – понедельник. Написать задачу в питоне

Показать ответ
Ответ:
Hahaha1234567890
Hahaha1234567890
11.04.2022 17:14
Программа с массивом (хотя он тут и не нужен):
var a:array[1..60] of char;
st:string; i,p:integer;
begin
writeln('Введите массив символов:');
readln(st);
writeln('Вот массив:');
for i:=1 to length(st) do 
 begin
 a[i]:=st[i];
 write(a[i]);
 end;
writeln;
st:=' '+st+' ';
p:=pos(' mama ',st);
while p>0 do
 begin
 delete(st,p,6);
 insert(' ded ',st,p);
 p:=pos(' mama ',st);
 end;
writeln('Измененный массив:');
for i:=1 to length(st)-2 do 
 begin
 a[i]:=st[i+1];
 write(a[i]);
 end;
writeln;
end.

Пример:
Введите массив символов:
mama papa okno mama primer baba
Вот массив:
mama papa okno mama primer baba
Измененный массив:
ded papa okno ded primer baba
0,0(0 оценок)
Ответ:
керамбит1
керамбит1
25.01.2020 22:51
На будущее: за программу никто писать не будет.
Программа, возможно, не совершенна (т.е. по-любому, можно было сделать короче), однако работает. Написана на Pascal, тестировал в веб-среде PascalABC.

var mo,tu,we,th,fr,sa,su,a: ShortInt;
var b: Real;
Begin
Write('Температура воздуха в Понедельник: ');
Readln(mo);
Write('Температура воздуха во Вторник: ');
Readln(tu);
Write('Температура воздуха в Среду: ');
Read(we);
Write('Температура воздуха в Четверг: ');
Readln(th);
Write('Температура воздуха в Пятницу: ');
Readln(fr);
Write('Температура воздуха в Субботу: ');
Readln(sa);
Write('Температура воздуха в Воскресенье: ');
Readln(su);
a:=mo+tu+we+th+fr+sa+su;
b:=a/7;
Write('Средняя температура воздуха: ',b:0:2,' градусов.');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота