В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dolgunovadaniela
dolgunovadaniela
14.11.2021 04:49 •  Информатика

Составить программу, которая подсчитывает количество четных чисел,количество нечетных чисел, сумму и среднее арифметическое в последовательности которая закачивает 0

Показать ответ
Ответ:
beregnoy2017
beregnoy2017
05.10.2020 10:33
Program n1;
var a,kch,knc,k,sum: integer;
begin
write('введите 1 член последовательности: ');
readln(a);
knc:=0;
sum:=0;
kch:=0;
k:=0;
while a<>0 do begin
k:=k+1;
if a mod 2=0 then kch:=kch+1 else
knc:=knc+1;
sum:=sum+a;
write('введите следущий член: ');
readln(a);
end;
writeln('сумма: ',sum);
writeln('кол-во четных: ',kch);
writeln('кол-во нечетных: ',knc);
writeln('ср. арифмитическое: ',sum/k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота