В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
smail212313
smail212313
25.08.2022 02:14 •  Информатика

Составить программу, которая подсчитывает общее количество целых пятизначных чисел, составленных из различных цифр, которые тем свойством, что число, образованное первыми двумя цифрами, будучи умноженным на среднюю цифру, даёт число, образованное последними двумя цифрами.

Показать ответ
Ответ:
roman5555554
roman5555554
09.07.2020 22:48
Var
  a, b, c, d, e, n: integer;

begin
  n := 0;
  for a := 1 to 9 do
    for b := 0 to 9 do
      for c := 1 to 9 do
        for d := 0 to 9 do
          for e := 0 to 9 do
            if (10 * a + b) * c = (10 * d + e) then n := n + 1;
  Writeln(n)
end.

Тестовое решение:
196
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота