В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Dimasgta7
Dimasgta7
07.05.2023 01:52 •  Информатика

Составить программу, которая получает новую строку, удалив из первоначальной строки третье слово

Показать ответ
Ответ:
nadezdaakopan
nadezdaakopan
07.10.2020 11:43
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadlnString.ToWords; // читаем строку, образуем массив слов
  var s:=(a[:2]+a[3:]).JoinIntoString; // получаем новую строку
  Writeln(s) // вывод...
end.

Пояснения.
a - массив с индексами от 0 до n-1, где n - число слов.
Срез a[:2] возвращает последовательность элементов массива 0 и 1.
Срез a[3:] возвращает последовательность элементов массива, начиная с третьего и до конца массива. Объединение последовательностей порождает необходимый набор слов, который объединяется в строку через пробел при

Пример
А роза упала на лапу Азора
А роза на лапу Азора
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота