В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
АРТЁМ55567
АРТЁМ55567
29.07.2020 02:26 •  Информатика

Составить программу, которая посчитает сумму натуральных чисел из промежутка от 1 до 100, которые делятся на 17 и сумма цифр, которых не превышает 7. в паскале.

Показать ответ
Ответ:
gryzzly12
gryzzly12
23.07.2020 08:56
{сумма натуральных чисел из промежутка от 1 до 100,
которые делятся на 17 и сумма цифр, которых не
превышает 7. Можно перебором}
var i,s:integer;
begin
 s:=0;
 for i:=1 to 100 do
 if  (i mod 17=0) and (i div 10 + i mod 10<7) then
 s:=s+i;
 writeln(s);
end.
{результат 51}

{
Можно оптимизировать
в цикле изменив  for i:=1 to 100 do
на
 for i:=17 to 100 do}

{2 вариантө оптимальнее - перебираем только числа кратные 17]
var i,s:integer;
begin
 s:=0; i:=17;
 while i<=100 do
 begin
   if  (i div 10 + i mod 10<7) then
   s:=s+i;
   i:=i+17;
 end;
 writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота