В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
динара259
динара259
27.01.2023 18:59 •  Информатика

Составить программу, которая проверяла бы, не приводит ли суммирование двух целых чисел а и в к переполнению (т.е. к результату большему чем 32 767). если будет переполнение, то сообщить об этом, иначе вывести сумму этих чисел.

Показать ответ
Ответ:
nastyamal0101
nastyamal0101
19.06.2020 10:05
Int A,B,Summ
A+B=Summ
if (Summ>32767) cout>>"Переполнение"
else cout>>"Summ"
0,0(0 оценок)
Ответ:
Dasha292001
Dasha292001
19.06.2020 10:05
Var
a, b, s  : Integer;
begin
Write('введите a= ');
readln(a);
Write('введите b= ');
readln(b);
S:=a+b;
if s<32767 then writeln(s) else writeln('произошло переполнение');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота