В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
VIRUS00000
VIRUS00000
26.12.2020 12:20 •  Информатика

Составить программу которая считает количество цифр 7 в записи натурального числа.

PASCAL

Показать ответ
Ответ:
olegovnao27
olegovnao27
15.10.2020 00:39

var

 a, count: integer;

begin

 count := 0;

 read(a);

 while a > 0 do

 begin

   if a mod 10 = 7 then

     count := count + 1;

   a := a div 10;

 end;

 writeln(count);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота